PT-2025-21795
CVE-2025-47273
·
Published
2025-05-17
·
Updated
2026-10-13
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
setuptools versions prior to 78.1.1
Description
A path traversal vulnerability in
PackageIndex was found in setuptools. An attacker would be allowed to write files to arbitrary locations on the filesystem with the permissions of the process running the Python code, which could escalate to remote code execution depending on the context.Recommendations
Update setuptools to version 78.1.1 or later to fix the vulnerability. For Debian 11 bullseye, update to version 52.0.0-4+deb11u2 or later. For other distributions, follow the recommended update instructions.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾