PT-2025-21912
CVE-2025-37891
·
Published
2025-05-19
·
Updated
2026-10-13
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.93
Description
The Linux kernel contains a buffer overflow in the ALSA subsystem, specifically within the UMP (Unified MIDI Packet) SysEx message conversion process. The
do convert to ump() function uses an internal buffer of size 4 to store incoming MIDI bytes, assuming a maximum size of 4 for MIDI1 UMP packet data. However, SysEx messages can be up to 6 bytes long, leading to a buffer overflow when processing these messages. This can potentially corrupt memory. The fix involves increasing the buffer size to 6 to accommodate SysEx messages. This vulnerability was discovered by an AI-powered vulnerability hunter named Argusee and may enable Local Privilege Escalation (LPE).Recommendations
Upgrade to Linux kernel version 6.6.93 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾