PT-2025-22408

CVE-2025-47291

·

Published

2025-05-21

·

Updated

2025-11-27

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions containerd versions 2.0.1 through 2.0.4
Description A bug was found in containerd's CRI implementation where it doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, causing some Kubernetes limits to not be honored. This may lead to a denial of service of the Kubernetes node.
Recommendations For containerd versions 2.0.1 through 2.0.4, update to version 2.0.5 or later, or 2.1.0 or later, to resolve the issue. As a temporary workaround, consider disabling usernamespaced pods in Kubernetes until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-CXFP-7PVR-95FF
AZL-62003
GO-2025-3701
OPENSUSE-SU-2025:15159-1
OPENSUSE-SU-2025:15454-1
OPENSUSE-SU-2025:20117-1
OPENSUSE-SU-2026:20798-1
Found an issue in the description? Have something to add? Feel free to write us 👾