PT-2025-22998
CVE-2025-5244
·
Published
2025-04-09
·
Updated
2026-09-29
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
GNU Binutils versions up to 2.44
Description
A critical issue was found in GNU Binutils, affecting the
elf gc sweep function of the ld component. This issue leads to memory corruption and can be exploited locally. The exploit has been disclosed publicly and may be used.Recommendations
For GNU Binutils versions up to 2.44, upgrade to version 2.45 to address this issue. As a temporary workaround, consider disabling the
elf gc sweep function until a patch is available. Restrict access to the bfd/elflink.c file to minimize the risk of exploitation. Avoid using the affected ld component until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾