PT-2025-23428
CVE-2025-40908
·
Published
2025-06-01
·
Updated
2026-08-20
Description by
CVSS 2.0
9.4
CriticalMetricsAV:N/AC:L/Au:N/C:C/I:C/A:N
Name of the Vulnerable Software and Affected Versions
YAML-LibYAML versions prior to 0.903.0
Description
YAML-LibYAML uses a two-argument
open function when parsing YAML files, which allows an attacker to modify existing files on the system. This flaw allows a local attacker to provide a crafted YAML file as input, resulting in unauthorized file modification.Recommendations
Update YAML-LibYAML to version 0.903.0 or later.
Run
sudo pro fix USN-7632-1 to apply the fix.
Update to package version libyaml-libyaml-perl - 0.89+ds-1ubuntu0.24.04.1.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾