PT-2025-25224

CVE-2025-49146

·

Published

2025-06-11

·

Updated

2026-09-18

Description by

CVSS 2.0
8.5
High
MetricsAV:N/AC:L/Au:N/C:C/I:P/A:N
Name of the Vulnerable Software and Affected Versions pgjdbc versions 42.7.4 through 42.7.6
Description The issue arises when the PostgreSQL JDBC driver is configured with channel binding set to required, allowing connections to proceed with authentication methods that do not support channel binding, such as password, MD5, GSS, or SSPI authentication. This could enable a man-in-the-middle attacker to intercept connections that users believed were protected by channel binding requirements.
Recommendations For pgjdbc versions 42.7.4 through 42.7.6, update to version 42.7.7 to resolve the issue. As a temporary workaround, consider configuring sslMode=verify-full to prevent man-in-the-middle attacks.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-HQ9P-PM7W-8P54
BIT-POSTGRESQL-JDBC-DRIVER-2025-49146
CLEANSTART-2026-XL50889
ECHO-9F55-F2F4-C741
OPENSUSE-SU-2025:15264-1
Found an issue in the description? Have something to add? Feel free to write us 👾