PT-2025-25771
CVE-2025-31698
·
Published
2025-01-01
·
Updated
2025-07-25
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Apache Traffic Server versions 9.0.0 through 9.2.10
Apache Traffic Server versions 10.0.0 through 10.0.6
Description
The issue arises when the ACL configured in ip allow.config or remap.config does not utilize IP addresses provided by the PROXY protocol. A new setting,
proxy.config.acl.subjects, can be used to select which IP addresses to use for the ACL when Apache Traffic Server is set up to accept the PROXY protocol.Recommendations
For versions 9.0.0 through 9.2.10, upgrade to version 9.2.11.
For versions 10.0.0 through 10.0.6, upgrade to version 10.0.6.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾