PT-2025-26689

CVE-2025-47943

·

Published

2025-06-24

·

Updated

2025-08-04

Description by

CVSS 3.1
6.3
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
Name of the Vulnerable Software and Affected Versions: Gogs versions 0.14.0+dev and prior
Description: Gogs is an open source self-hosted Git service. The issue is a stored cross-site scripting (XSS) vulnerability, which allows client-side Javascript code execution. This is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20, located in public/plugins/.
Recommendations: For versions 0.14.0+dev and prior, update to version 0.13.3 or later to resolve the issue. As a temporary workaround, consider disabling the pdfjs-1.4.20 component under public/plugins/ until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-XH32-CX6C-CP4V
GO-2025-3778
OPENSUSE-SU-2025:15405-1
Found an issue in the description? Have something to add? Feel free to write us 👾