PT-2025-26943

CVE-2025-5459

·

Published

2025-06-26

·

Updated

2025-10-14

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Puppet Enterprise versions 2018.1.8 through 2023.8.3 Puppet Enterprise version 2025.3
Description: A user with specific node group editing permissions and a specially crafted class parameter could execute commands as root on the primary host.
Recommendations: For Puppet Enterprise versions 2018.1.8 through 2023.8.3, update to version 2023.8.4. For Puppet Enterprise version 2025.3, update to version 2025.4.0.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾