PT-2025-27359

CVE-2025-5878

·

Published

2025-06-29

·

Updated

2026-09-15

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions: ESAPI esapi-java-legacy versions prior to 2.7.0.0
Description: A vulnerability was found in the interface Encoder.encodeForSQL of the SQL Injection Defense, leading to an improper neutralization of special elements. The attack may be initiated remotely. This issue affects the SQL Injection Defense, allowing for potential exploitation. The project handled the issue professionally after being contacted.
Recommendations: For versions prior to 2.7.0.0, upgrade to version 2.7.0.0 to address this issue. As a temporary workaround, consider disabling the Encoder.encodeForSQL interface until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DLA-4246-1
RHLW-2026-CC6F4A613453615E
USN-8181-1
Found an issue in the description? Have something to add? Feel free to write us 👾