PT-2025-2766
CVE-2024-47408
·
Published
2024-12-11
·
Updated
2026-10-03
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Linux kernel versions prior to 6.6.74
Description:
The issue arises when receiving a proposal message in the server, where the
smcd v2 ext offset field from the remote client cannot be fully trusted. If the value of smcd v2 ext offset exceeds the maximum value, it may lead to accessing the wrong address, potentially causing a crash. This is resolved by checking the value of smcd v2 ext offset before using it.Recommendations:
For versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue. As a temporary workaround, consider restricting access to the
net/smc module until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾