PT-2025-28011
CVE-2025-52497
·
Published
2025-06-30
·
Updated
2026-08-25
Description by
CVSS 3.1
4.8
MediumMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L
Name of the Vulnerable Software and Affected Versions:
Mbed TLS versions prior to 3.6.4
Description:
The issue is related to a PEM parsing one-byte heap-based buffer underflow in Mbed TLS, specifically in the
mbedtls pem read buffer and two mbedtls pk parse functions. This occurs when the software processes untrusted PEM input.Recommendations:
For versions prior to 3.6.4, update to version 3.6.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
mbedtls pem read buffer and mbedtls pk parse functions to minimize the risk of exploitation. Avoid using untrusted PEM input until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾