PT-2025-28649
CVE-2025-48386
·
Published
2025-07-08
·
Updated
2025-10-09
Description by
CVSS 3.1
8.6
HighMetricsAV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Git versions prior to 2.43.7
Git versions prior to 2.44.4
Git versions prior to 2.45.4
Git versions prior to 2.46.4
Git versions prior to 2.47.3
Git versions prior to 2.48.2
Git versions prior to 2.49.1
Git versions prior to 2.50.1
Description:
The wincred credential helper in Git does not properly bounds check the available space remaining in a static buffer before appending to it with wcsncat(), leading to potential buffer overflows.
Recommendations:
For versions prior to 2.43.7, update to version 2.43.7 or later.
For versions prior to 2.44.4, update to version 2.44.4 or later.
For versions prior to 2.45.4, update to version 2.45.4 or later.
For versions prior to 2.46.4, update to version 2.46.4 or later.
For versions prior to 2.47.3, update to version 2.47.3 or later.
For versions prior to 2.48.2, update to version 2.48.2 or later.
For versions prior to 2.49.1, update to version 2.49.1 or later.
For versions prior to 2.50.1, update to version 2.50.1 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾