PT-2025-28848

CVE-2025-27613

·

Published

2025-01-01

·

Updated

2026-09-25

Description by

CVSS 3.1
3.6
Low
MetricsAV:L/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions: Git versions 2.43.7 through 2.49.1
Description: The issue allows for the creation and truncation of any writable file when a user clones an untrusted repository and runs Gitk without additional command arguments, provided the "Support per-file encoding" option is enabled. Additionally, the operation "Show origin of this line" is affected, regardless of the option being enabled or not. Multiple vulnerabilities were fixed in Git, including arbitrary code execution and buffer overflows.
Recommendations: For Git versions 2.43.7 through 2.49.1, update to a version newer than 2.49.1 to resolve the issue. As a temporary workaround, consider disabling the "Support per-file encoding" option and restricting the use of Gitk until a patch is available. Avoid using the "Show origin of this line" operation in Gitk for untrusted repositories until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-F3CW-XRJ3-WR2V
ALSA-2025:11462
ALSA-2025:11533
ALSA-2025:11534
ALT-PU-2025-10893
ALT-PU-2025-9420
ALT-PU-2025-9640
AZL-65073
AZL-65076
CESA-2025_11534
DLA-4323-1
ECHO-B1D0-A192-7995
INFSA-2025_11462
INFSA-2025_11534
OESA-2025-1844
OESA-2025-1845
OESA-2025-1846
OESA-2025-1847
OESA-2025-1848
OESA-2025-1849
OESA-2026-3879
OESA-2026-3880
OESA-2026-4068
OPENSUSE-SU-2025:15337-1
RHSA-2025:11462
RHSA-2025_11462
RHSA-2025:11533
RHSA-2025:11534
RHSA-2025_11534
SUSE-SU-2025:03012-1
SUSE-SU-2025_03012-1
SUSE-SU-2025:03022-1
SUSE-SU-2025_03022-1
SUSE-SU-2025:03037-1
SUSE-SU-2025_03037-1
SUSE-SU-2025:20721-1
SUSE-SU-2025:20855-1
USN-7626-1
USN-7626-2
USN-7626-3
Found an issue in the description? Have something to add? Feel free to write us 👾