PT-2025-29119
CVE-2025-49812
·
Published
2025-04-22
·
Updated
2026-07-14
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions:
Apache HTTP Server versions through 2.4.63
Description:
In certain mod ssl configurations, a man-in-the-middle attacker can hijack an HTTP session through a TLS upgrade attack. This issue affects configurations utilizing “SSLEngine optional” to enable TLS upgrades. The attack is related to HTTP desynchronization.
Recommendations:
Upgrade to version 2.4.64, which removes support for TLS upgrade.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾