PT-2025-2930
CVE-2024-52332
·
Published
2024-10-23
·
Updated
2026-10-21
Description by
CVSS 3.1
7.1
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.74
Description
The issue concerns a potential invalid memory access in the
igb init module() function. This occurs when the pci register driver() function fails, and the dca notifier is not unregistered, leading to its potential invocation when the igb module fails to install.Recommendations
For versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue.
As a temporary workaround, consider disabling the
igb init module() function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾