PT-2025-32995
CVE-2025-55004
·
Published
2025-04-08
·
Updated
2026-07-30
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:N/C:C/I:P/A:P
Name of the Vulnerable Software and Affected Versions:
ImageMagick versions prior to 7.1.2-1
Description:
ImageMagick is vulnerable to a heap-buffer overflow read when handling images with separate alpha channels during image magnification in the
ReadOneMNGImage function. This issue can potentially leak memory contents into the output image.Recommendations:
Update to version 7.1.2-1 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾