PT-2025-32999
CVE-2025-55163
·
Published
2025-08-13
·
Updated
2026-10-12
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Netty versions prior to 4.1.124.Final
Netty versions prior to 4.2.4.Final
Description:
Netty is an asynchronous, event-driven network application framework vulnerable to a MadeYouReset DDoS attack. This issue is a logical vulnerability in the HTTP/2 protocol, triggered by malformed HTTP/2 control frames that bypass the maximum concurrent streams limit, leading to resource exhaustion and a distributed denial of service.
Recommendations:
Netty versions prior to 4.1.124.Final: Update to version 4.1.124.Final or later.
Netty versions prior to 4.2.4.Final: Update to version 4.2.4.Final or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾