PT-2025-33103
CVE-2025-55198
·
Published
2025-08-13
·
Updated
2026-09-18
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions:
Helm versions prior to 3.18.5
Description:
Helm is a package manager for Charts for Kubernetes. An improper validation of type error when parsing
Chart.yaml and index.yaml files can lead to a panic. This issue impacts YAML validation where a Chart.yaml file has a null maintainer or the child or parent of a dependencies import-values can be parsed as something other than a string, causing helm lint to panic. Additionally, an empty entry in the list of chart versions within an index.yaml can cause Helm to panic.Recommendations:
Update to Helm version 3.18.5 or later.
Ensure YAML files are formatted as Helm expects prior to processing them with Helm.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾