PT-2025-33104
CVE-2025-55199
·
Published
2025-08-13
·
Updated
2026-09-21
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions:
Helm versions prior to 3.18.5
Description:
Helm, a package manager for Kubernetes Charts, is susceptible to a denial-of-service issue. A crafted JSON Schema file can cause Helm to exhaust available memory, leading to an out-of-memory (OOM) termination. This occurs when the
$ref field in values.schema.json points to a device or problematic file, such as /dev/zero.Recommendations:
Helm versions prior to 3.18.5 should be updated to version 3.18.5 or later.
Ensure all Helm charts loaded into Helm do not have any reference of
$ref pointing to /dev/zero.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾