PT-2025-33268
CVE-2025-8714
·
Published
2025-08-13
·
Updated
2026-09-28
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 17.6
PostgreSQL versions prior to 16.10
PostgreSQL versions prior to 15.14
PostgreSQL versions prior to 14.19
PostgreSQL versions prior to 13.22
Description
Untrusted data inclusion in the
pg dump utility allows a malicious superuser of the origin server to inject arbitrary code. This code is executed during the restore process as the client operating system account running psql to restore the dump, achieved through the use of psql meta-commands. The pg dumpall utility is also affected, as is pg restore when it is used to generate a plain-format dump.Recommendations
Update to version 17.6
Update to version 16.10
Update to version 15.14
Update to version 14.19
Update to version 13.22
Found an issue in the description? Have something to add? Feel free to write us 👾