PT-2025-3332
CVE-2024-56785
·
Published
2024-11-23
·
Updated
2026-08-23
Description by
CVSS 3.1
5.5
MediumMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.74
Description
A vulnerability in the Linux kernel has been resolved, specifically related to the MIPS Loongson64 architecture. The issue involved fixing PCIe port nodes for ls7a and resolving dtc warnings. A runtime warning was introduced due to deprecated #address-cells/#size-cells handling. The fix is similar to a previous commit that resolved the issue for ls2k.
Recommendations
Update to Linux kernel version 6.6.74 or later to resolve the issue.
As a temporary workaround, consider disabling the vulnerable PCIe port nodes for ls7a until a patch is available.
Restrict access to the affected PCI bridge to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾