PT-2025-34153

CVE-2025-54988

·

Published

2025-08-20

·

Updated

2026-11-03

Description by

CVSS 4.0
10
Critical
MetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Name of the Vulnerable Software and Affected Versions Apache Tika versions 1.13 through 3.2.1
Description An XML External Entity (XXE) injection issue exists in the tika-parser-pdf-module due to improper restriction of XML references to external objects. An attacker can exploit this by providing a specially crafted XFA file embedded within a PDF, potentially allowing them to read sensitive data or trigger malicious requests to internal resources or third-party servers. This issue affects tika-core, tika-pdf-module, and tika-parsers, and is a dependency for several packages including tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc, and tika-server-standard.
Recommendations Upgrade Apache Tika to version 3.2.2.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-F58C-GQ56-VJJF
GHSA-P72G-PV48-7W9X
DLA-4350-1
USN-8324-1
Found an issue in the description? Have something to add? Feel free to write us 👾