PT-2025-34482

CVE-2025-54813

·

Published

2025-01-01

·

Updated

2025-11-05

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:C/A:N
Name of the Vulnerable Software and Affected Versions: Apache Log4cxx versions prior to 1.5.0
Description: The software contains an improper output neutralization issue for logs. When using JSONLayout, not all payload bytes are properly escaped. Attackers can supply messages containing non-printable characters that will be passed along and written as part of the JSON message, potentially preventing applications consuming these logs from correctly interpreting the information.
Recommendations: Upgrade to version 1.5.0.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾