PT-2025-34928

CVE-2025-58050

·

Published

2025-08-27

·

Updated

2026-07-27

Description by

CVSS 2.0
9.4
Critical
MetricsAV:N/AC:L/Au:N/C:C/I:N/A:C
Name of the Vulnerable Software and Affected Versions: PCRE2 library versions prior to 10.46
Description: The PCRE2 library contains a heap-buffer-overflow read vulnerability in the regular expression matching engine. The issue occurs within the handling of the (*scs:...) (Scan SubString) verb when combined with (*ACCEPT) in src/pcre2 match.c. This may lead to information disclosure if the out-of-bounds data read during the memcmp function affects the final match result.
Recommendations: Update to PCRE2 library version 10.46 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-C2GV-XGF5-5CC2
ALT-PU-2025-11010
OPENSUSE-SU-2025:15501-1
OPENSUSE-SU-2026:20512-1
PYSEC-2025-259
SUSE-SU-2026:21094-1
SUSE-SU-2026:21172-1
USN-7777-1
Found an issue in the description? Have something to add? Feel free to write us 👾