PT-2025-3596
CVE-2024-57850
·
Published
2024-07-23
·
Updated
2026-10-21
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.74
Description
The issue is related to the jffs2 rtime decompression routine, which does not fully check bounds during decompression and can corrupt memory outside the decompression buffer if the compressed data is corrupted. This can lead to memory corruption.
Recommendations
For versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue. As a temporary workaround, consider restricting the use of the jffs2 file system until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾