PT-2025-3656

CVE-2024-57931

·

Published

2024-12-05

·

Updated

2026-10-19

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 6.6.74
Description The issue concerns the Linux kernel, specifically the SELinux module, where unknown extended permissions were not handled properly. When evaluating extended permissions, the kernel will now ignore unknown permissions instead of calling BUG(). This change ensures that future permissions can be added without interfering with older kernels.
Recommendations For Linux kernel versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue. As a temporary workaround, consider restricting the use of extended permissions until the update is applied.
Exploitability
Exploit
Fix
Vendors
Affected products
Weakness enumeration
Related identifiers
CLSA-2025-1746479711
DLA-4075-1
DLA-4076-1
INFSA-2025_6966
MGASA-2025-0030
MGASA-2025-0032
OESA-2025-1159
OESA-2025-1160
OESA-2025-1161
OESA-2025-2554
OESA-2025-2555
OPENSUSE-SU-2025_0428-1
OPENSUSE-SU-2025_0499-1
OPENSUSE-SU-2025_0557-1
RHSA-2025:6966
RHSA-2025_6966
SUSE-SU-2025:0428-1
SUSE-SU-2025_0428-1
SUSE-SU-2025:0499-1
SUSE-SU-2025_0499-1
SUSE-SU-2025:0557-1
SUSE-SU-2025_0557-1
SUSE-SU-2025:0564-1
SUSE-SU-2025:0565-1
SUSE-SU-2025:20165-1
SUSE-SU-2025:20166-1
SUSE-SU-2025:20248-1
SUSE-SU-2025:20249-1
USN-7379-1
USN-7379-2
USN-7380-1
USN-7381-1
USN-7382-1
USN-7387-1
USN-7387-2
USN-7387-3
USN-7388-1
USN-7389-1
USN-7390-1
USN-7391-1
USN-7392-1
USN-7392-2
USN-7392-3
USN-7392-4
USN-7393-1
USN-7401-1
USN-7407-1
USN-7413-1
USN-7421-1
USN-7458-1
USN-7459-1
USN-7459-2
USN-7463-1
USN-7513-1
USN-7513-2
USN-7513-3
USN-7513-4
USN-7513-5
USN-7514-1
USN-7515-1
USN-7515-2
USN-7522-1
USN-7523-1
USN-7524-1
USN-7539-1
USN-7540-1
Found an issue in the description? Have something to add? Feel free to write us 👾