PT-2025-39463
CVE-2025-56769
·
Published
2025-09-25
·
Updated
2025-10-03
Description by
CVSS 4.0
8.9
HighMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Name of the Vulnerable Software and Affected Versions
hutool versions prior to 5.8.4
Description
An issue exists in the QLExpressEngine class that allows attackers to execute arbitrary expressions, potentially leading to arbitrary method invocation and remote code execution (RCE).
Recommendations
Update to a version newer than 5.8.4.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾