PT-2025-39625

CVE-2025-11042

·

Published

2025-09-25

·

Updated

2026-10-19

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions GitLab CE/EE versions 17.2 through 18.2.6 GitLab CE/EE versions 18.3 through 18.3.2 GitLab CE/EE versions 18.4 through 18.4.0
Description The software contains an issue that allows an attacker to cause uncontrolled CPU consumption, potentially leading to a Denial of Service (DoS) condition when using specific GraphQL queries.
Recommendations Update GitLab CE/EE to version 18.2.7 or later. Update GitLab CE/EE to version 18.3.3 or later. Update GitLab CE/EE to version 18.4.1 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
BIT-GITLAB-2025-11042
Found an issue in the description? Have something to add? Feel free to write us 👾