PT-2025-39710
CVE-2025-10954
·
Published
2025-09-27
·
Updated
2026-10-19
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
github.com/nyaruka/phonenumbers versions prior to 1.2.2
Description
The package contains an issue related to improper validation of input syntax within the
phonenumbers.Parse() function. Providing specifically crafted input can lead to a panic, resulting in a "slice bounds out of range" runtime error.Recommendations
Update to version 1.2.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾