PT-2025-39734

CVE-2025-8014

·

Published

2025-09-27

·

Updated

2026-10-19

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions GitLab EE/CE versions 11.10 through 18.2.7 GitLab EE/CE versions 18.3 through 18.3.3 GitLab EE/CE versions 18.4 through 18.4.1
Description A denial of service issue exists in GraphQL endpoints within GitLab EE/CE. This allows unauthenticated users to potentially bypass query complexity limits, which can lead to resource exhaustion and service disruption. The issue affects the GraphQL API.
Recommendations Update GitLab EE/CE to version 18.2.8 or later. Update GitLab EE/CE to version 18.3.4 or later. Update GitLab EE/CE to version 18.4.2 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
BIT-GITLAB-2025-8014
Found an issue in the description? Have something to add? Feel free to write us 👾