PT-2025-40878
CVE-2025-59732
·
Published
2025-08-05
·
Updated
2026-08-07
Description by
CVSS 4.0
8.7
HighMetricsAV:A/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
Name of the Vulnerable Software and Affected Versions
OpenEXR versions prior to 8.0
Description
An issue exists in decoding OpenEXR files that utilize DWAA or DWAB compression. The software implicitly assumes image height and width are divisible by 8. When this condition is not met, copy loops can write beyond allocated buffer boundaries, potentially leading to heap memory corruption. The
td->uncompressed data buffer, allocated during the decode block process, is susceptible to being exceeded by the copy loop when the image dimensions are not multiples of 8. This can result in corruption of adjacent heap memory.Recommendations
Upgrade to version 8.0 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾