PT-2025-4104
CVE-2025-0939
·
Published
2025-01-31
·
Updated
2025-03-02
Description by
CVSS 3.1
6.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
MagicForm plugin for WordPress versions up to, and including, 1.6.2
Description
The issue arises from a missing capability check on the plugin's AJAX actions, allowing authenticated attackers with Subscriber-level access and above to invoke those actions. This enables them to delete or view logs, modify forms, or modify plugin settings.
Recommendations
For MagicForm plugin for WordPress versions up to, and including, 1.6.2, update to a version higher than 1.6.2 to resolve the issue. As a temporary workaround, consider restricting access to the plugin's AJAX actions to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾