PT-2025-4139

CVE-2025-20033

·

Published

2025-01-09

·

Updated

2025-01-30

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Mattermost versions 9.11.x through 9.11.5 Mattermost versions 10.0.x through 10.0.3 Mattermost versions 10.1.x through 10.1.3 Mattermost version 10.2.0
Description The issue is related to improper validation of post types in Mattermost, which allows attackers to deny service to users with the sysconsole read plugins permission. This can be achieved by creating a post with the custom pl notification type and specific properties.
Recommendations For Mattermost versions 9.11.x through 9.11.5, update to a version newer than 9.11.5 to resolve the issue. For Mattermost versions 10.0.x through 10.0.3, update to a version newer than 10.0.3 to resolve the issue. For Mattermost versions 10.1.x through 10.1.3, update to a version newer than 10.1.3 to resolve the issue. For Mattermost version 10.2.0, update to a version newer than 10.2.0 to resolve the issue. As a temporary workaround, consider restricting the use of the custom pl notification post type to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-2549-XH72-QRPM
GO-2025-3379
OPENSUSE-SU-2025_0297-1
OPENSUSE-SU-2025:14644-1
SUSE-SU-2025:0297-1
Found an issue in the description? Have something to add? Feel free to write us 👾