PT-2025-4232
CVE-2025-21493
·
Published
2025-01-21
·
Updated
2025-01-22
Description by
CVSS 2.0
4.9
MediumMetricsAV:N/AC:H/Au:S/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
MySQL Server versions 8.4.3 and prior
MySQL Server versions 9.1.0 and prior
Description
The issue is related to the MySQL Server product, specifically the Server: Security: Privileges component. It allows a high-privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks can result in the unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. The vulnerability is difficult to exploit and can be triggered remotely through the MySQL network protocol.
Recommendations
For MySQL Server versions 8.4.3 and prior, update to a version later than 8.4.3 to resolve the issue.
For MySQL Server versions 9.1.0 and prior, update to a version later than 9.1.0 to resolve the issue.
As a temporary workaround, consider restricting network access to MySQL Server to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾