PT-2025-4432
CVE-2025-22317
·
Published
2025-01-03
·
Updated
2025-01-15
Description by
CVSS 3.1
7.1
HighMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
Photo Gallery – Image Gallery by Ape versions prior to 2.2.8
Description
The issue is related to improper neutralization of input during web page generation, which allows reflected Cross-site Scripting (XSS). This enables attackers to inject malicious scripts into the website.
Recommendations
For versions prior to 2.2.8, update to version 2.2.8 or later to resolve the issue.
As a temporary workaround, consider restricting user input to minimize the risk of exploitation.
Avoid using potentially vulnerable API endpoints until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾