PT-2025-45150

CVE-2025-31954

·

Published

2025-11-05

·

Updated

2026-10-18

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions HCL iAutomate versions 6.5.1 through 6.5.2
Description HCL iAutomate versions 6.5.1 and 6.5.2 have a sensitive information disclosure issue. The application uses an HTTP GET method to process requests, including sensitive information within the query string. This could allow an attacker to access unintended information or resources. The vulnerable request uses the ''/'' API endpoint with sensitive data in the query string. The parameter query string contains the sensitive information.
Recommendations Update HCL iAutomate to a version newer than 6.5.2.
Exploitability
Fix
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾