PT-2025-46568
CVE-2025-12018
·
Published
2025-11-11
·
Updated
2026-10-18
Description by
CVSS 3.1
4.4
MediumMetricsAV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
MembershipWorks – Membership, Events & Directory plugin for WordPress versions prior to 6.14
Description
The plugin is susceptible to Stored Cross-Site Scripting through admin settings due to inadequate input sanitization and output escaping. This allows authenticated attackers with administrator-level permissions or higher to inject arbitrary web scripts into pages. These scripts will execute when a user accesses the injected page. This issue only impacts multi-site installations and those where unfiltered html has been disabled.
Recommendations
Update to a version newer than 6.14.
Found an issue in the description? Have something to add? Feel free to write us 👾