PT-2025-46823
CVE-2025-12817
·
Published
2025-11-13
·
Updated
2026-09-18
Description by
CVSS 3.1
3.1
LowMetricsAV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 18.1
PostgreSQL versions prior to 17.7
PostgreSQL versions prior to 16.11
PostgreSQL versions prior to 15.15
PostgreSQL versions prior to 14.20
PostgreSQL versions prior to 13.23
Description
A flaw exists in the PostgreSQL
CREATE STATISTICS command where insufficient authorization checks can lead to a denial of service. A table owner can negatively impact other users attempting to use CREATE STATISTICS by creating statistics in any schema. A subsequent CREATE STATISTICS operation, initiated by a user with the necessary CREATE privilege, will then fail.Recommendations
Update to PostgreSQL version 18.1 or later.
Update to PostgreSQL version 17.7 or later.
Update to PostgreSQL version 16.11 or later.
Update to PostgreSQL version 15.15 or later.
Update to PostgreSQL version 14.20 or later.
Update to PostgreSQL version 13.23 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾