PT-2025-47185
CVE-2025-64756
·
Published
2025-11-17
·
Updated
2026-09-18
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Glob versions 10.3.7 through 11.0.3
Description
The glob command-line interface contains a command injection issue in its -c/--cmd option. This allows arbitrary command execution when processing files with maliciously crafted names. When using
glob -c <command> <patterns>, matched filenames are passed to a shell, and shell metacharacters within filenames can trigger command injection, leading to arbitrary code execution with the privileges of the user or CI account. The cmd option is vulnerable.Recommendations
Update to version 11.1.0 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾