PT-2025-48236
CVE-2025-12758
·
Published
2025-11-27
·
Updated
2026-09-11
Description by
CVSS 4.0
7.7
HighMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P
Name of the Vulnerable Software and Affected Versions
validator versions prior to 13.15.22
Description
The package validator, in versions prior to 13.15.22, contains an issue related to incomplete filtering of special elements within the
isLength() function. Specifically, the function does not properly account for Unicode variation selectors (e.g., uFE0F, uFE0E) when calculating string length. This can result in the function accepting strings that are longer than expected, potentially leading to data truncation, buffer overflows, or denial-of-service conditions. The issue stems from improper string length calculation.Recommendations
Update to validator version 13.15.22 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾