PT-2025-48986

CVE-2025-12385

·

Published

2025-10-31

·

Updated

2026-06-24

Description by

CVSS 4.0
8.7
High
MetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Name of the Vulnerable Software and Affected Versions Qt versions 5.0.0 through 6.5.10 Qt versions 6.6.0 through 6.8.5 Qt versions 6.9.0 through 6.10.0
Description A flaw exists in Qt’s Text component that involves improper validation of the width and height specified in the tag. This can lead to excessive resource allocation, potentially causing applications to become unresponsive. The issue impacts users of the Text component across multiple platforms including Windows, MacOS, Linux, iOS, and Android, and affects both 32-bit and 64-bit architectures.
Recommendations Update to a version beyond 6.5.10 Update to a version beyond 6.8.5 Update to a version beyond 6.10.0
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
AZL-71555
AZL-71647
OESA-2025-2844
OESA-2025-2845
OESA-2025-2846
OESA-2025-2870
OESA-2025-2871
OESA-2025-2872
OESA-2025-2873
OESA-2025-2874
USN-8357-1
Found an issue in the description? Have something to add? Feel free to write us 👾