PT-2025-49134

CVE-2024-58278

·

Published

2025-12-04

·

Updated

2026-09-26

Description by

CVSS 4.0
8.5
High
MetricsAV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Name of the Vulnerable Software and Affected Versions perl2exe versions prior to 30.10C
Description perl2exe versions prior to 30.10C contain an arbitrary code execution issue. Local authenticated attackers can exploit this to execute malicious scripts. Specifically, attackers can control the 0th argument of packed executables, enabling them to execute another executable and bypass restrictions, ultimately gaining unauthorized access.
Recommendations Update perl2exe to a version greater than 30.10C.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾