PT-2025-4914

CVE-2025-23509

·

Published

2025-01-16

·

Updated

2025-01-23

Description by

CVSS 3.1
7.1
High
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions HyperComments versions 0.9.6 and earlier
Description The issue is related to improper neutralization of input during web page generation, which allows for reflected Cross-site Scripting (XSS). This enables attackers to inject malicious scripts into web pages, potentially leading to unauthorized actions or data theft.
Recommendations For HyperComments versions 0.9.6 and earlier, update to a version later than 0.9.6 to resolve the issue. As a temporary workaround, consider restricting user input to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾