PT-2025-49455

CVE-2022-50614

·

Published

2022-09-07

·

Updated

2026-02-24

Description by

CVSS 2.0
6.0
Medium
MetricsAV:L/AC:H/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 6.0.0-rc1rpci-dev+ #237
Description The Linux kernel contained a flaw in the pci endpoint test module where the dma map single() function did not properly handle zero-length mappings, leading to a potential kernel panic. This issue was reported following a panic observed on arm64 systems during testing. The root cause was identified in the swiotlb tbl map single() function.
Recommendations Update to version 6.0.0-rc1rpci-dev+ #237 or a later version to resolve this issue.
Exploitability
Exploit
Fix
Vendors
Affected products
Related identifiers
RHSA-2025:6966
SUSE-SU-2026:0263-1
SUSE-SU-2026:0317-1
SUSE-SU-2026:0411-1
SUSE-SU-2026:0617-1
Found an issue in the description? Have something to add? Feel free to write us 👾