PT-2025-51356

CVE-2025-67744

·

Published

2025-12-16

·

Updated

2026-10-10

Description by

CVSS 3.1
9.6
Critical
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions DeepChat versions prior to 0.5.3
Description DeepChat is an open-source artificial intelligence agent platform. A security issue exists in the Mermaid diagram rendering component that allows arbitrary JavaScript execution. This Cross-Site Scripting (XSS) flaw escalates to full Remote Code Execution (RCE), enabling an attacker to execute arbitrary system commands. The issue is caused by the exposure of the Electron IPC renderer to the DOM, combined with unsafe Mermaid configuration and an exposed IPC interface.
Recommendations Update DeepChat to version 0.5.3 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-W8W8-82PV-5RG9
Found an issue in the description? Have something to add? Feel free to write us 👾