PT-2025-52412

CVE-2025-14546

·

Published

2025-12-19

·

Updated

2026-10-05

Description by

CVSS 3.1
6.3
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
Name of the Vulnerable Software and Affected Versions fastapi-sso versions prior to 0.19.0
Description The software is susceptible to Cross-site Request Forgery (CSRF) because of inadequate validation of the OAuth state parameter during the authentication callback. The get login url method generates a state value but does not store it or associate it with the user’s session. Subsequently, the verify and process method accepts the state parameter from query parameters without comparing it to a trusted, locally stored value. This allows an attacker to deceive a user into visiting a malicious callback URL, potentially linking the attacker’s account to the user’s internal account.
Recommendations Update to version 0.19.0 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-HP6R-R9VC-Q8WX
PYSEC-2026-1362
Found an issue in the description? Have something to add? Feel free to write us 👾