PT-2025-53659
CVE-2025-68973
·
Published
2025-01-01
·
Updated
2026-10-13
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
GnuPG versions prior to 2.4.9
GnuPG versions 2.2.51 and earlier
Description
The issue resides in the
armor filter function within the g10/armor.c file. A flaw exists due to two increments of an index variable where only one is intended. This leads to an out-of-bounds write condition when processing crafted input. Exploitation of this issue by a remote attacker could potentially lead to arbitrary code execution through the submission of a specially crafted PGP message. The vulnerability is related to an integer overflow.Recommendations
GnuPG versions prior to 2.4.9: Upgrade to version 2.4.9 or later.
GnuPG versions 2.2.51 and earlier: Upgrade to version 2.2.51 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾