PT-2025-6048
CVE-2024-11831
·
Published
2024-09-16
·
Updated
2026-10-15
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
npm-serialize-javascript versions up to 6.0.1
Description
The vulnerability occurs because the serialize-javascript module does not properly sanitize certain inputs, such as regex or other JavaScript object types, allowing an attacker to inject malicious code. This code could be executed when deserialized by a web browser, causing Cross-site scripting (XSS) attacks. This issue is critical in environments where serialized data is sent to web clients, potentially compromising the security of the website or web application using this package.
Recommendations
For npm-serialize-javascript versions up to 6.0.1, update to a version higher than 6.0.1 to resolve the issue. As a temporary workaround, consider disabling the use of the serialize-javascript module until a patch is available. Restrict access to sensitive data and minimize the use of serialized data in web clients to reduce the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾