PT-2025-6085
CVE-2024-42512
·
Published
2025-02-09
·
Updated
2025-03-03
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:N/C:C/I:P/A:P
Name of the Vulnerable Software and Affected Versions
OPC UA .NET Standard Stack versions prior to 1.5.374.158
Description
The issue allows an unauthorized attacker to bypass application authentication when the deprecated Basic128Rsa15 security policy is enabled.
Recommendations
For versions prior to 1.5.374.158, update to version 1.5.374.158 or later to resolve the issue. As a temporary workaround, consider disabling the deprecated Basic128Rsa15 security policy until a patch is available. Restrict access to the application when the Basic128Rsa15 security policy is enabled to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾